Ubuntuでnokogiri gemをインストール

ruby1.9をインストールして、Ubuntuでnokogiriをインストールしようと、失敗してしまった。

 

ググると、公式で説明されていた。

Nokogiri 鋸

 

説明はruby1.8が前提らしいため、ruby1.9に置き換えて読みつつ説明通りに実行してインストールする。

 

$ sudo apt-get install ruby-dev ruby ri rdoc irb
$ sudo apt-get install libreadline-ruby libruby libopenssl-ruby

$ sudo apt-get install libxslt-dev libxml2-dev
$ sudo gem install nokogiri
Successfully installed nokogiri-1.5.6
1 gem installed
Installing ri documentation for nokogiri-1.5.6…
Installing RDoc documentation for nokogiri-1.5.6…

成功。

現在のUbuntuのaptパッケージでは、ruby1.9-devはruby-devといった感じのパッケージ名になっているため、公式の説明に対して全て1.8を取り除いたパッケージ名で実行するとうまくいく。

 

Linux系は、たいていの依存関係がaptパッケージのインストールで解決するから助かるわー。

コメントを残す

トラックバック: http://pgnote.net/wp-trackback.php?p=2163